This project is read-only.

Will there be an official release anytime soon?

Dec 18, 2011 at 2:18 PM

First of all let me express my atmost gratitude for the existence of this project.  I'm trying to use the currently released 1.0.1 version but am running into some issues. Cloning the repository I noticed that the build msi has a 1.2 version. Will there be a public release anytime soon of this 1.2 version? I tried to build and install from the sources but ran into problems. So I would really appreciate an effort to release an update.


Dec 19, 2011 at 7:50 PM

The short answer: yes, there is a 1.2 release coming very soon.  I'm hoping on the 23rd of December; however I have another obligation which may push this to the next week.

Please log any specific issues you're having with the 1.0.1 release on the issue tracker (; I would also ask that you also report the issues you're having with the build as well.  This is the only way I can make sure these things get addressed outside of a patch request.

In the meantime, if you simply cannot wait I can send you an MSI for a local build - just send me a private note either through my Codeplex profile ( or using the contact form on my blog ( and I will get you an MSI today.

Dec 21, 2011 at 2:36 PM

Thanks for your reply. In hindsight it appears the problem I ran up against with 1.0.1 was the feature of VS that disables 'misbehaving' addins. If the user sends powershell into some infinite loop VS disables StudioShell for the next startup.  Furthermore StudioShell currently doesn't support nested prompts, I will submit an issue about this. The build had some problems because DataVisualization for .net 3.5 SP1 was not installed on my system.  

Dec 21, 2011 at 4:36 PM

Ah, ok.  Any chance you can share the code that caused the infinite loop?  was it as simple as while ($true){} ?

Ah, nice catch - I'll add the binaries for datavis to the lib folder and modify the project references accordingly.

Thanks for logging the issues...  I'm hoping to have a release ready by Friday Dec 23rd.

Dec 21, 2011 at 7:50 PM

Can't quite recall the exact code that causes the failure, maybe the infinite loop is a bit of an exaggeration on my part. I'll see if I can find some example that shows the behavior. As far as the dependency goes, I guess, I was also thrown of by the fact that the 4.0 framework has the datavisualization assembly in it. The 23rd of December sounds like an awesome christmas present, thanks for your efforts.